options de rendu

Inkscape est un logiciel de dessin vectoriel basé sur le format SVG.
Panzenoni
Messages : 2
Inscription : 30 août 2016, 13:12

options de rendu

Message par Panzenoni »

J’aimerais pouvoir exporter en format PNG des dessins faits en SVG avec Inkscape, mais sans niveau de gris. Autrement dit, je cherche à obtenir un rendu composé de noir et de blanc uniquement; mais je ne sais pas comment m'y prendre...
Merci pour votre aide!
undertaker
Messages : 1477
Inscription : 05 janv. 2005, 20:58
Localisation : LIEGE - BELGIQUE

Re: options de rendu

Message par undertaker »

Bonjour Panzenoni,

Si tu dessines en noir dans ta page de dessin puis que tu places un rectangle rempli de blanc derrière ton dessin (via les calques peut-être), tu exporte en bitmap en noir et blanc avec un fond blanc.
Si tu ne places pas de forme remplie de blanc en arrière tu exporteras avec le dessin en noir et un fond transparent.

A+
COGITO ERGO SUM.
Linux DEBIAN 10, Inkscape 0.92, Scribus 1.4.8 et aussi Gimp, Blender, ...
jazzynico
Admin d'Inkscape-fr
Messages : 56
Inscription : 27 oct. 2008, 21:31

Re: options de rendu

Message par jazzynico »

Bonjour,

Ah, ce serait tellement pratique d'avoir davantage d'options pour exporter du PNG. Il existe à ce propos une demande d'évolution dans le gestionnaire de rapports d'Inkscape.
On doit sans doute pouvoir y arriver avec les filtres SVG, mais là, comme ça, je n'arrive qu'à faire de la teinte de gris.

Sinon, il reste la possibilité de travailler à postériori sur le fichier PNG généré, avec ImageMagick et la commande convert. Tu trouveras plus d'informations (en anglais) dans le forum superuser.
Xubuntu 16.04 (Inkscape 0.92/master 64-bit), Windows 7 (0.92/master 64-bit).
Panzenoni
Messages : 2
Inscription : 30 août 2016, 13:12

Re: options de rendu

Message par Panzenoni »

Merci pour vos conseils.
Undertaker, j'ai suivi ce que tu m’as proposé, mais ça n'a rien résolu...
Sinon; t’as raison Jazzynico, je comprends pas pourquoi on peut pas choisir d'exporter en bitmap. Vivement une mise à jour pour régler ça. :mrgreen:
Répondre