message d'erreur avec povray et Kpovmodeler HELP !

Outils (comme KPovmodeler ou Terraform par exemple) permettant de créer des images 3D avec POV-Ray sous Linux.
sylvana
P'tit timide
P'tit timide
Messages : 5
Inscription : 04 nov. 2004, 17:50

message d'erreur avec povray et Kpovmodeler HELP !

Message par sylvana »

Bonjour tout le monde,
quand j'ouvre Kpovmodeler et que je tente un rendu sur la scène original (un cube, ouaisss!) j'obtiens le message d'erreur Povray suivant (je le met inextenso, désolé) :
Persistence of Vision(tm) Ray Tracer Version 3.1g.Linux.gcc
This is an unofficial version compiled by:
Mandrakesoft SA...........................
The POV-Ray Team(tm) is not responsible for supporting this version.
Copyright 1999 POV-Ray Team(tm)
Parsing Options
Input file: /tmp/kde-rachel/kpovmodeler8NpO2b.pov (compatible to version 3.1)
Remove bounds........On Split unions........Off
Library paths: /usr/lib/povray31 /usr/lib/povray31/include
Output Options
Image resolution 640 by 480 (rows 1 to 480, columns 1 to 640).
Output file: stdout, 24 bpp Targa
Graphic display.....Off
Mosaic preview......Off
CPU usage histogram.Off
Continued trace.....Off Allow interruption...On Pause when done.....Off
Verbose messages....Off
Tracing Options
Quality: 9
Bounding boxes.......On Bounding threshold: 25
Light Buffer.........On Vista Buffer.........On
Antialiasing........Off
Radiosity...........Off
Animation Options
Initial Frame.. 1 Final Frame.... 1
Initial Clock.. 0.000 Final Clock.... 0.000
Cyclic Animation....Off Field render........Off Odd lines/frames....Off
Redirecting Options
All Streams to console..........On
Debug Stream to console.........On
Fatal Stream to console.........On
Render Stream to console........On
Statistics Stream to console....On
Warning Stream to console.......On


Parsing...global_settings {
assumed_gamma 1.5

noise_generator <----ERROR

/tmp/kde-rachel/kpovmodeler8NpO2b.pov:3: error: No matching } in global_settings, undeclared identifier 'noise_generator' found instead.


Qu'est-ce qui se passe ? Que puis-je faire ?
Merci de votre aide
Informations importantes : OS=mandrake 10.1 Community (instable il est vrai)
J'ai installé ma carte Nvidia et elle marche pour tout a priori
Voili voila
Bon dimanche et à bientôt
Sylvana
Librement

Raymond
Admin de Gimp-fr
Messages : 707
Inscription : 25 août 2004, 18:09
Localisation : Strasbourg
Contact :

Message par Raymond »

Ta version de POV est visiblement trop vieille.
Aujourd'hui la version courante est 3.6.1 (et pas 3.1g)
http://www.povray.org/download/ section Linux

@+

olivierb
Administrateur
Administrateur
Messages : 106
Inscription : 11 mai 2004, 21:26
Localisation : Nord de la France
Contact :

Message par olivierb »

Je confirme qu'il faut au moins la version 3.5 de POV-Ray pour KPovModeleur même si celui-ci n'utilise pas toutes les possibilités de celui-ci.

Par contre j'avoue ne pas avoir testé KPM avec la version 3.6 . :oops:
olivierb

olivs
Administrateur
Administrateur
Messages : 2090
Inscription : 28 avr. 2004, 08:23
Localisation : Toulouse
Contact :

Message par olivs »

olivierb a écrit :Par contre j'avoue ne pas avoir testé KPM avec la version 3.6 . :oops:
olivierb


moi oui, ça marche sans histoire :wink:

Répondre