Problème de texture sur une forme cylindrique

Blender: Grand logiciel open source de création d'images 3D.
julienbarrat
Messages : 1
Inscription : 22 févr. 2010, 17:04

Problème de texture sur une forme cylindrique

Message par julienbarrat »

Bonjour,
débutant sur Blender, je me débrouille comme je peux pour créer les formes de mes objets, et je viens de rencontrer un problème inattendu sur lequel l'un d'entre vous aura peut être une solution.
Voici la forme sous trois angles différents :

http://www.casimages.com/img.php?i=1002 ... 693601.png

Je l'ai construite en faisant trois objets : deux parallélépipèdes rectangles sur les côtés, et un fragment de cylindre dédoublé au milieu. En fait j'ai construit un cylindre (sans "Caps end"), dont j'ai supprimé la moitié avant de le dupliquer, puis je n'ai gardé que les points nécessaires pour obtenir ma forme. Pour finir, j'ai créé des faces entre les lignes de chaque moitié de cylindre. Je ne sais pas trop si je suis clair, donc voici la forme vue du dessous sans texture :

http://www.casimages.com/img.php?i=1002 ... 923669.png

Désolé pour cette introduction un peu longue, je vous explique le problème maintenant...En fait, quand j'essaye de texturiser les faces du dessous, je les sélectionne toutes, puis je passe en vue de dessous (Shift + 7), je fais U (en Edit Mode), "Project from view (Bounds)" puis je fous ma texture, mais contrairement aux autres faces, la texture est imprimée à l'intérieur de l'objet, et pire, les faces du dessous apparaissent transparentes en mode textures visibles (Alt + Z)!

Est-ce que quelqu'un a une idée de comment résoudre le problème? J'ai essayé de mettre la texture en vue du dessus, au cas où cela puisse résoudre le souci de le prendre à l'envers, mais non, ca ne marche pas.

Merci d'avance de vos réponses.

julien.
melwe
Messages : 444
Inscription : 22 avr. 2007, 02:46
Localisation : Nancy

Re: Problème de texture sur une forme cylindrique

Message par melwe »

Salut, et bienvenue sur le forum !
Ça m'a tout l'air d'un soucis de normales. As-tu essayé de faire Ctrl+n pour recalculer les normales vers l'extérieur de l'objet automatiquement ?
Bon courage !
Répondre