[resolu] python

Blender: Grand logiciel open source de création d'images 3D.
jack
Messages : 19
Inscription : 15 janv. 2005, 18:23
Localisation : normandie
Contact :

[resolu] python

Message par jack »

Bonjour, à l'epoque j'utiliser blender 2.36 et j'exportais avec povanim vers povray, j'aimerai retrouver cette configuration mais je ne sais plus quel est la version compatible de python qu'il faut installer pour eviter le "error check console",j'aimerai aussi utiliser blender 2.37 mais quel est la version de python compatible?
Merci d'avance. :D
bonjour, je débute dans la 3D avec Blender et c'est génial,je m'entraine a reproduire Gus et dans le tuto on me que dit que je peut augmenter le rayon d'influence en edition proportionnelle en pressant NUM+ et num-, je ne trouve pas ! merci
rore
Administrateur
Administrateur
Messages : 755
Inscription : 05 août 2005, 15:24
Localisation : Bretagne
Contact :

Message par rore »

Si je me souvient bien, Blender2.36 utilisait python 2.3, et Blender 2.37a ...euh... python 2.3 ou 2.4.
Sinon, comme il s'agit de povanim je pense que tu pourrais poser la question directement à JMSoler ;)
Avatar de l’utilisateur
ILTL
Messages : 8
Inscription : 27 nov. 2005, 10:16
Localisation : France
Contact :

Message par ILTL »

Blender 2.37 utilise python 2.3 et blender 2.4 utilise python.......2.4 :D
Par contre moi j'ai bien blender 2.4 et python 2.4 aussi mais pourtant les scripts python refusent de fonctionner!
Si vous avez une idée parce que je commence à désespérer...
Merci d'avance!
@++
:lol:
rore
Administrateur
Administrateur
Messages : 755
Inscription : 05 août 2005, 15:24
Localisation : Bretagne
Contact :

Message par rore »

ILTL: lance blender depuis une console, et dis nous les messages d'erreur que tu rencontres?
Et quand tu parles des scripts python: ceux de base fourni avec blender (là ça m'étonnerais :) ), ou bien des scripts externes?
Si c'est le dernier cas, il me semble qu'il y a la marche à suivre pour spécifier correctement ton pythonpath, dans un des tutos d'OlivS (http://www.linuxgraphic.org/pdf/blender-lg-01.pdf partie "1.1 Regler le pythonpath" uniquement )
Avatar de l’utilisateur
ILTL
Messages : 8
Inscription : 27 nov. 2005, 10:16
Localisation : France
Contact :

Message par ILTL »

Voila ce qu'il me dit au démarrage avec Blender2.40:
Using Python version 2.4
'import site' failed; use -v for traceback
Et ce qu'il me dit quand j'ai une erreur avec python:
Traceback (most recent call last):
File "<string>", line 126, in ?
ImportError: No module named math
Or, j'ai bien le module math!
Je vais de ce pas voir le tuto, il se peut que ce soit la solution (tant attendue) à mon problème!
Merci beaucoup!

[edit]
J'ai le problème sur tout les scripts, meme ceux intégrés à Blender!
J'ai testé avec Kloputil, Pydoc browser, Bevel center, Knife tool, ...

Je viens de suivre le tuto mais ça ne change rien...

[/edit]
:lol:
jack
Messages : 19
Inscription : 15 janv. 2005, 18:23
Localisation : normandie
Contact :

confirmation

Message par jack »

yes, c'est bien ça: Python 2.3 pour blender 2.36 ou 2.37 et installer python dans le repertoire Blender,merci ça dechire! :lol:
bonjour, je débute dans la 3D avec Blender et c'est génial,je m'entraine a reproduire Gus et dans le tuto on me que dit que je peut augmenter le rayon d'influence en edition proportionnelle en pressant NUM+ et num-, je ne trouve pas ! merci
jms
Messages : 56
Inscription : 20 sept. 2007, 21:33

Message par jms »

rore a écrit :Si je me souvient bien, Blender2.36 utilisait python 2.3, et Blender 2.37a ...euh... python 2.3 ou 2.4.
Sinon, comme il s'agit de povanim je pense que tu pourrais poser la question directement à JMSoler ;)


Bonne idée.
Répondre