Voir les messages sans réponses | Voir les sujets actifs Nous sommes le 23 Aoû 2014, 21:46



Répondre au sujet  [ 4 messages ] 
[Résolu] Horrible trainée verte !! 
Auteur Message
P'tit timide
P'tit timide

Inscription: 31 Oct 2007, 22:41
Messages: 3
Message [Résolu] Horrible trainée verte !!
Bonjour,

Je viens de passer de Ubuntu 7.04 à 7.10, avec au passage une mise à jour de la version de Gimp (de 2.2 à 2.4 RC3).

L'outil crayon (ou pinceau ou effacer...) laisse une trainée verte sur l'image en cours lorsque je déplace le pointeur. Elle correspond à la taille de l'outil. Cette trace est fictive en ce sens qu'elle ne fait pas partie de l'image et n'est pas conservée lors de l'enregistrement de l'image. De même, elle disparaît si je rétrécis l'image ou si je l'agrandis.

Je ne sais pas si c'est normal, mais c'est très désagréable à l'usage.

Voici une copie d'écran qui illustre le problème :

Image

Quelqu'un a-t-il déjà rencontré ce problème ?
Ou une idée pour le résoudre ?
Est-ce une nouvelle fonctionnalité ?


Merci de me renseigner.

Daniel


Dernière édition par Daniel D le 01 Nov 2007, 12:48, édité 1 fois.



31 Oct 2007, 22:54
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 11 Déc 2006, 14:46
Messages: 101
Localisation: Touraine, entre Loire et Vienne
Message 
peut-être passer simplement de la 2.4rc3 à la 2.4 finale? voire la 2.4.1:wink:


01 Nov 2007, 11:37
Profil Site Internet
P'tit timide
P'tit timide

Inscription: 31 Oct 2007, 22:41
Messages: 3
Message 
Citation:
peut-être passer simplement de la 2.4rc3 à la 2.4 finale? voire la 2.4.1


La version 2.4rc3 est celle qui est fournie par ubuntu. Mais j'ai le même problème avec la 2.4 fournie par arch.

J'ai fini par touver une solution. Un autre post de ce forum parle du même problème ; c'est ici.

C'est aparemment un problème du pilote de la carte graphique, si j'ai bien compris. Je l'ai résolu en ajoutant la ligne
Code:
   Option      "AccelMethod"    "EXA"

dans la section Device de mon fichier xorg.conf.

Chez moi, ça résouds le problème, sans que je sache vraiment quel changement apporte cette ligne au niveau de l'affichage...

J'espère que cette astuce pourra aider.

A+

Daniel


01 Nov 2007, 12:47
Profil
P'tit timide
P'tit timide

Inscription: 31 Oct 2007, 22:41
Messages: 3
Message 
Citation:
peut-être passer simplement de la 2.4rc3 à la 2.4 finale? voire la 2.4.1


C'était en fait la meilleure solution. A l'usage, les modifications faites au fichier xorg.conf réglaient bien le problème pour gimp, mais en créaient d'autres (impossibilité d'utiliser les effets 3D - compiz et Cie, ralentissement de firefox, et j'en passe).

Le problème des trainées vertes est bien un bug du pilote graphique, mais la version 2.4.1 de Gimp permet de le contourner en modifiant le fichier /etc/gimp/2.0/gimprc.

Il faut décommenter la ligne suivante :
Code:
# (xor-color (color-rgb 0.501961 1.000000 0.501961))

et la modifier comme ceci :
Code:
 (xor-color (color-rgb 1.000000 1.000000 1.000000))

Résultat : plus de trainée verte, sans toucher à la configuration de Xorg.

Voilà.

A+

Daniel


11 Nov 2007, 19:14
Profil
Afficher les messages postés depuis:  Trier par  
Répondre au sujet   [ 4 messages ] 

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot], Google Feedfetcher et 0 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Forum style by ST Software for PTF.
Traduction par: phpBB-fr.com