Voir les messages sans réponses | Voir les sujets actifs Nous sommes le 17 Jan 2018, 19:41



Répondre au sujet  [ 5 messages ] 
Message erreur Inkscape avec copier/coller 
Auteur Message
P'tit timide
P'tit timide

Inscription: 04 Fév 2015, 13:09
Messages: 2
Répondre en citant le message
Message Message erreur Inkscape avec copier/coller
Bonjour,

J'ai un message d'erreur quand je sélectionne un objet d'un fichier svg pour le coller dans une autre feuille svg.
Le fichier a été créé par inkscape (sous windows je n'ai pas d'erreur). J'ai la même erreur quand j'ouvre le fichier pdf généré par inkscape.

Code:
UniConvertor failed:

Cannot list directory /home/moi/.uniconvertor:[Errno 2] No such file or directory: '/home/moi/.uniconvertor'
ignoring it in font_path
Cannot list directory /home/moi/.uniconvertor:[Errno 2] No such file or directory: '/home/moi/.uniconvertor'
ignoring it in font_path
Cannot load plugin module sk1saver
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/uniconvertor/app/plugins/plugins.py", line 73, in load_module
    desc)
  File "/usr/lib/python2.7/dist-packages/uniconvertor/app/plugins/Filters/sk1saver.py", line 249, in <module>
    from app.Graphics.image import CMYK_IMAGE
ImportError: cannot import name CMYK_IMAGE
When importing plugin sk1saver
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/uniconvertor/app/plugins/plugins.py", line 190, in __call__
    module = self.load_module()
  File "/usr/lib/python2.7/dist-packages/uniconvertor/app/plugins/plugins.py", line 73, in load_module
    desc)
  File "/usr/lib/python2.7/dist-packages/uniconvertor/app/plugins/Filters/sk1saver.py", line 249, in <module>
    from app.Graphics.image import CMYK_IMAGE
ImportError: cannot import name CMYK_IMAGE
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/uniconvertor/__init__.py", line 88, in uniconv
    saver(doc, output_file)
  File "/usr/lib/python2.7/dist-packages/uniconvertor/app/plugins/plugins.py", line 194, in __call__
    % {'name':self.module_name})
app.events.skexceptions.SketchError: Cannot load filter sk1saver


J'ai vérifié dans Synaptic, j'ai bien le paquet uniconvertor mais dans

Code:
/user/bin


Comment régler ce problème ?

Merci


04 Fév 2015, 13:12
Profil
Que quelqu'un le fasse taire!
Que quelqu'un le fasse taire!

Inscription: 05 Jan 2005, 20:58
Messages: 1259
Localisation: LIEGE - BELGIQUE
Répondre en citant le message
Message Re: Message erreur Inkscape avec copier/coller
Bonsoir,

Il faudrait vérifier si tu as bien Python 2.7 installé sur ta machine.

Depuis la version 3.0 de Python, de nombreuses choses ont changé et la compatibilité d'applications développées en 2.7 n'est plus garantie avec 3..x.
Il semble bien, d'après les messages affichés que Inkscape ne retrouve pas les fonctions dont il a besoin avec la version 2.7 de Python.

A+

_________________
COGITO ERGO SUM.
Linux DEBIAN 8, Inkscape 0.91, Scribus 1.4.1 et aussi Gimp, Blender, ...


04 Fév 2015, 18:57
Profil Site Internet
P'tit timide
P'tit timide

Inscription: 04 Fév 2015, 13:09
Messages: 2
Répondre en citant le message
Message Re: Message erreur Inkscape avec copier/coller
Bonsoir,
D'après synaptic, j'ai python 2.7 (2.7.6.8), python2.7 minimal et autres librairies.

J'ai oublié de préciser que ma version d'inkscape est 0.48.4 r9939, installée via logithèque d'ubuntu.

Je ne maîtrise aucun code informatique, je suis passé à linux pour le plaisir de ne plus avoir Windows.

Dois-je installer une nouvelle version d'inkscape ? Je n'ai pas trouvé le ppa pour ubunty 14.04.

Merci


04 Fév 2015, 20:50
Profil
Moulin à paroles
Moulin à paroles

Inscription: 12 Fév 2009, 17:54
Messages: 291
Répondre en citant le message
Message Re: Message erreur Inkscape avec copier/coller
Je suis sous Fedora 20 avec cette version d'Inkscape : 0.48.5 r10040
J'ai aussi le même type d'erreur de temps à autre (avec parfois un crash ...) mais ça ne m'empêche pas vraiment de travailler pour autant.

Pour info, j'ai abandonné Ubuntu au bout d'un an d'utilisation pour Fedora, qui est beaucoup, beaucoup plus réactif en termes de prise en compte des nouvelles versions. Surtout pour les logiciels photos - que j'utilise en permanence - qui ont très fréquemment des mises à jour, et je ne pouvais pas me permettre d'avoir régulièrement 6 mois de retard sur la dernière version stable.

_________________
Photographe en Cévennes
Mes livres-photos réalisés avec Scribus


04 Fév 2015, 23:55
Profil Site Internet
Que quelqu'un le fasse taire!
Que quelqu'un le fasse taire!

Inscription: 05 Jan 2005, 20:58
Messages: 1259
Localisation: LIEGE - BELGIQUE
Répondre en citant le message
Message Re: Message erreur Inkscape avec copier/coller
Et on ne le répétera jamais assez : Ubuntu, même s'il fournit une approche très "microsftienne" rassurante, souffre de bien des défauts de microsoft : il adapte les logiciel à son système et donc crée des bogues incessants voire certaines incompatibilités avec le même logiciel mais utilisés sous un autre OS Linux.

Moi aussi, j'ai commencé avec Ubuntu pour "voir ce que c'est Linux" puis, après quelques mois d'adaptation, je suis passé à Debian. Et moi aussi, je m'y trouve très très bien avec des sites extrêmement réactifs et très professionnels.

A+

_________________
COGITO ERGO SUM.
Linux DEBIAN 8, Inkscape 0.91, Scribus 1.4.1 et aussi Gimp, Blender, ...


05 Fév 2015, 10:44
Profil Site Internet
Afficher les messages postés depuis:  Trier par  
Répondre au sujet   [ 5 messages ] 

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 4 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Forum style by ST Software for PTF.
Traduction par: phpBB-fr.com