Voir les messages sans réponses | Voir les sujets actifs Nous sommes le 18 Déc 2018, 22:51



Répondre au sujet  [ 12 messages ] 
Problème avec le filtre Distortion ---> lentille optique 
Auteur Message
Chuchoteur
Chuchoteur

Inscription: 05 Avr 2015, 22:35
Messages: 21
Répondre en citant le message
Message Problème avec le filtre Distortion ---> lentille optique
Bonjour,

J'ai un problème avec l'utilisation du filtre Distorsion ---> lentille optique
http://pix.toile-libre.org/upload/origi ... 346284.png
Lorsque je lance le filtre le résultat n'est pas complète
http://pix.toile-libre.org/upload/origi ... 346413.png

D’où peut provenir ce problème. Je précise que je travaille avec u processeur intel I5 et 8g de mémoire vive.

Merci d'avance pour la réponse


15 Sep 2015, 21:49
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
PHIFO a écrit:
Bonjour,

J'ai un problème avec l'utilisation du filtre Distorsion ---> lentille optique
http://pix.toile-libre.org/upload/origi ... 346284.png
Lorsque je lance le filtre le résultat n'est pas complète
http://pix.toile-libre.org/upload/origi ... 346413.png

D’où peut provenir ce problème. Je précise que je travaille avec u processeur intel I5 et 8g de mémoire vive.

Merci d'avance pour la réponse

Il y a une selection active?


16 Sep 2015, 02:01
Profil
Chuchoteur
Chuchoteur

Inscription: 05 Avr 2015, 22:35
Messages: 21
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
Non il n'y a pas de section active mais ça m'a mis la puce à l'oreille.

J'ai diminué légèrement la résolution et la définition et ça a fonctionné correctement. D'habitude je n'ai aucun problème avec la définition et la résolution que j'utilisais.

Apparemment ce filtre est gourmand et je pensais être tranquille avec un I5 et 8g de ram. Peut être que ce sera plus performant lorsque j'aurai équipé mon ordi d'un carte graphique performante. Pour l'instant j'utilise que celle de la carte mère.


17 Sep 2015, 08:27
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
PHIFO a écrit:
Non il n'y a pas de section active mais ça m'a mis la puce à l'oreille.

J'ai diminué légèrement la résolution et la définition et ça a fonctionné correctement. D'habitude je n'ai aucun problème avec la définition et la résolution que j'utilisais.

Apparemment ce filtre est gourmand et je pensais être tranquille avec un I5 et 8g de ram. Peut être que ce sera plus performant lorsque j'aurai équipé mon ordi d'un carte graphique performante. Pour l'instant j'utilise que celle de la carte mère.


Hmmm. Y'a effectivement un bug, si l'image fait plus de de 2600 pixels le filtre ne marche plus correctement... La carte graphique n'y changera rien.

Tu es sur quelle version de Gimp?


17 Sep 2015, 09:01
Profil
Chuchoteur
Chuchoteur

Inscription: 05 Avr 2015, 22:35
Messages: 21
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
J'ai la version 2.8 donc il ne devrait pas y avoir de problème.


17 Sep 2015, 18:56
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
PHIFO a écrit:
J'ai la version 2.8 donc il ne devrait pas y avoir de problème.

Je suis sur la 2.8 aussi et j'ai le problème. Par contre c'est le 'level' qui vient avec ma distro (2.8.10 in Ubuntu 14.04) et la dernière version de Gimp est la 2.8.14. Si tu es sur une distro Debian (Debian, Ubuntu, Mint...) tu peux installer la dernière version en utilisant le PPA d'Otto. Mais je ne sais pas si ce bug a été identifié et corrigé dans la 2.8.14.


18 Sep 2015, 09:47
Profil
Chuchoteur
Chuchoteur

Inscription: 05 Avr 2015, 22:35
Messages: 21
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
J'ai la même configuration (Gimp 2.8.10 et Ubuntu 14.04)

Je viens d'essayer d’installer le PPA d'Otto mais dans le terminal il m'indique " add-apt: command not found". donc je ne peux voir si 2.8.14 a solutionné le problème et on ne trouve pas sur le site de Gimp


18 Sep 2015, 10:26
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
PHIFO a écrit:
J'ai la même configuration (Gimp 2.8.10 et Ubuntu 14.04)

Je viens d'essayer d’installer le PPA d'Otto mais dans le terminal il m'indique " add-apt: command not found". donc je ne peux voir si 2.8.14 a solutionné le problème et on ne trouve pas sur le site de Gimp


Si, tu le trouveras ici mais c'est plus hardcore, tu recompiles tout toi-même (make configure/make/sudo make install)...

D'un autre côté, je ne vois pas de commande 'add-apt' mentionnée dans ce qui est indiqué:
Code:
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp


C'est "add-apt-repository" d'un seul tenant, pas "add-apt" avec un paramètre "-repository". T'as pas fait un copier/coller?


18 Sep 2015, 13:37
Profil
Chuchoteur
Chuchoteur

Inscription: 05 Avr 2015, 22:35
Messages: 21
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
Ça y est j'ai chargé Gimp 2.8.14, je ne sais pas pourquoi ça ne voulait pas marcher.

c'est pareil , ça bug.


19 Sep 2015, 00:28
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
PHIFO a écrit:
Ça y est j'ai chargé Gimp 2.8.14, je ne sais pas pourquoi ça ne voulait pas marcher.

c'est pareil , ça bug.


http://bugzilla.gnome.org :)


19 Sep 2015, 09:48
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
J'ai investigué le problème. Y'a bien un bug, mais on peut le contourner. Le bug n'a l'air de se produire que sur le calque initial (et ses copies par "Calque>Dupliquer"). Mais si tu clones le calque par "Calque>Nouveau depuis le visible", ca marchera correctement...

Edit: chanté victoire trop vite. En fait le problème apparaît sur de plus petits calques quand il n'y a pas de canal alpha, mais avec un canal alpha, il apparaît pour des images autour de 16Mpix. Et créer un nouveau calque comme je dis plus haut ne fait que créér un calque avec un canal alpha, et donc ne corrige pas vraiment le problème pour de très grosses images. Mébon, quelqu'un s'en occupe (ce qui ne veut pas dire que le correctif sera publié rapidement).


20 Sep 2015, 18:58
Profil
Bavardeur
Bavardeur
Avatar de l’utilisateur

Inscription: 24 Fév 2015, 22:18
Messages: 145
Répondre en citant le message
Message Re: Problème avec le filtre Distortion ---> lentille optique
Un bug bien décrit est un bug a moitié corrigé. Les développeurs ont trouvé très vite et sorti un patch. Reste plus qu'a ajouter le patch au repository et pour toi qu'à installer un des "nightly builds" quand ça sera fait.


21 Sep 2015, 14:55
Profil
Afficher les messages postés depuis:  Trier par  
Répondre au sujet   [ 12 messages ] 

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 6 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Forum style by ST Software for PTF.
Traduction par: phpBB-fr.com