Utiliser Exif sous Gimp

Gimp est le fabuleux logiciel open source de dessin 2D de qualité professionnelle.
Santuzza
Messages : 2
Inscription : 16 juin 2014, 17:03

Utiliser Exif sous Gimp

Message par Santuzza »

Bonjour,

Je souhaiterais pouvoir modifier les métadonnées de plusieurs images au fomat JPG, via Exif qui est normalement disponible sous Gimp. J'ai essayé de l'installer via l'archive exif-browser.tar.gz, mais je n'arrive pas à l'installer en ligne de commande (je suis sous Ubuntu 13.10). Peut-on m'éclairer sur le marche exacte à suivre pour installer cette archive, s'il vous plaît, afin d'arriver à accéder aux fonctionnalités d'Exif ?

En vous remerciant d'avance :)
undertaker
Messages : 1502
Inscription : 05 janv. 2005, 19:58
Localisation : LIEGE - BELGIQUE

Re: Utiliser Exif sous Gimp

Message par undertaker »

Bonjour Santuzza,

Nous avons bien peu d'infos pour pouvoir te venir en aide.
Il serait bon, après avoir lancé la procédure "./configure" de nous montrer le retour de la console.

Il est à peu près certain qu'il manque le fichier "make".
Il faut donc, au cas où cela se vérifie, s'assurer de sa disponibilité dans ton système (ton OS).
Pour Ubuntu, une visite ici sera profitable.

A+
COGITO ERGO SUM.
Linux DEBIAN 10, Inkscape 0.92, Scribus 1.4.8 et aussi Gimp, Blender, ...
Santuzza
Messages : 2
Inscription : 16 juin 2014, 17:03

Re: Utiliser Exif sous Gimp

Message par Santuzza »

Bonjour,

Merci pour cette réponse !

Je suis retournée fouiller sur la documentation francophone d'Ubuntu et le site où j'ai trouvé comment installer Exif.

La démarche que j'avais trouvé était la suivante :
gunzip exif-browser.tar.gz
tar xcf exif-browser.tar
cd exif-browser
./configure
make
sudo make install

Tout d'abord il me fallait complètement oublier la deuxième ligne de commande qui ne servait à rien, et j'ai pu ensuite aller jusqu'à ./configure, mais effectivement, "make" n'existe pas et cela me donne ceci :

lorinda@lorinda-Inspiron-3721:~$ cd exif-browser
lorinda@lorinda-Inspiron-3721:~/exif-browser$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking for strerror in -lcposix... no
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for pkg-config... /usr/bin/pkg-config
checking for gimp-2.0 gimpui-2.0 libexif >= 0.5.9... Package gimp-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gimp-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gimp-2.0' found Package gimpui-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gimpui-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gimpui-2.0' found Package libexif was not found in the pkg-config search path. Perhaps you should add the directory containing `libexif.pc' to the PKG_CONFIG_PATH environment variable No package 'libexif' found
configure: error: Library requirements (gimp-2.0 gimpui-2.0 libexif >= 0.5.9) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
lorinda@lorinda-Inspiron-3721:~/exif-browser$ make
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.
lorinda@lorinda-Inspiron-3721:~/exif-browser$

C'est donc bien le make qui manque, y compris dans le dossier décompressé, il n'y a que "Makefile.am" et Makefile.in".
undertaker
Messages : 1502
Inscription : 05 janv. 2005, 19:58
Localisation : LIEGE - BELGIQUE

Re: Utiliser Exif sous Gimp

Message par undertaker »

Bonjour Santuzza,

Ce problème de make manquant est habituel.

Un tuto pour son installation sous Ubuntu est .

A+
COGITO ERGO SUM.
Linux DEBIAN 10, Inkscape 0.92, Scribus 1.4.8 et aussi Gimp, Blender, ...
fabeos92
Messages : 2
Inscription : 08 déc. 2014, 19:01

Re: Utiliser Exif sous Gimp

Message par fabeos92 »

Bonjour,

On peut aussi modifier les métadonnées exif en ligne de commande et aussi les utiliser pour renommer les fichiers.

J'espère que ça aidera.
fabeos92
Raymond
Admin de Gimp-fr
Messages : 707
Inscription : 25 août 2004, 18:09
Localisation : Strasbourg
Contact :

Re: Utiliser Exif sous Gimp

Message par Raymond »

Le message d'erreur te suggère plutot que tu n'as pas installé le paquet gimp devel. Nécessaire pour compiler un greffon. C'est ce que je vérifierai en premier.

Ceci dit exifbrowser permet de modifier les données exif ? Il me semble pas, juste les lire.

exiftool autre outil pour modifier les exif
http://www.sno.phy.queensu.ca/~phil/exiftool/
Répondre