Voir les messages sans réponses | Voir les sujets actifs Nous sommes le 25 Juin 2018, 13:39



Répondre au sujet  [ 18 messages ]  Aller à la page 1, 2  Suivante
Problème de gestion de l'album 
Auteur Message
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Problème de gestion de l'album
Petite présentation :
Je fais partie d'une Amap et réalise une feuille de chou trimestrielle avec Scribus 1.4.6. Mon système d'exploitation est Windows 7.
Mon problème : (depuis hier)
J'ai créé un album dans mon répertoire Scribus/Amap/Album
Lorsque je mets un objet qui contient une image dans l'album et que je le récupère de l'album pour l'intégrer dans la feuille de chou, l'image a disparu.
En consultant la gestion des images, celle correspondant à l'image mise dans l'album est introuvable à l'adresse de l'album et une croix rouge s'affiche à la place.
J'ai testé ;
- la récupération d'un ancien objet de l'album : ça fonctionne (l'image apparait).
- la re-mise dans l'album de cet ancien objet et sa récup (L'image n'apparait plus).
- En allant dans "Extra - Gestion des images" :
- l'image correspondant à l'ancien objet récupéré de l'album apparait avec dans information :
- le chemin de l'album
- son format et toutes ses infos
- l'image correspondant au nouvel objet n'apparait pas (une grosse croix rouge à la place) et aucune infos sur son format. Par contre le chemin est correcte (l'album).
A priori l'enregistrement de l'objet dans l'album ne se fait pas dans mon album créé. :mrgreen:
Que dois-je faire ? :?: Quelqu'un peut-il m'aider ?
Merci d'avance
Alain


12 Nov 2017, 12:56
Profil
Moulin à paroles
Moulin à paroles

Inscription: 12 Fév 2009, 17:54
Messages: 335
Répondre en citant le message
Message Re: Problème de gestion de l'album
À ma connaissance, l'album n'enregistre pas l'image elle-même ; seulement le cadre et ses caractéristiques, pour réutilisation ultérieure dans un autre document (ou le même).

_________________
Photographe en Cévennes
Mes livres-photos réalisés avec Scribus


12 Nov 2017, 15:20
Profil Site Internet
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Merci Tosca,
j'ai été un peu plus loin dans mes recherches :
Le dossier Amap_Album contient :

- Pour les anciens objets mis dans l'album (exemple objet "A_La_Loupe" contenant 2 images) :
Amap_Album\A_La_Loupe\Haricot_Vert.Jpg
Amap_Album\A_La_Loupe\Loupe.Jpg
Amap_Album\A_La_Loupe.Png
Amap_Album\A_La_Loupe.Sce

- Pour les nouveaux objets mis dans l'album (exemple objet "A_La_Loupe(0)") :
Amap_Album\A_La_Loupe(0) Dossier vide
Amap_Album\A_La_Loupe(0).Png
Amap_Album\A_La_Loupe(0).Sce
Les images sont à priori enregistrées dans C\users\mon nom\AppData\Roaming\Scribus\Scrapbook\Main\A_La_Loupe(0) et pas dans le dossier "Amap_Album".
Je ne comprends pas ce qui a pu changer et encore moins ce que je dois faire.
Merci encore
Alain


12 Nov 2017, 18:33
Profil
Moulin à paroles
Moulin à paroles

Inscription: 12 Fév 2009, 17:54
Messages: 335
Répondre en citant le message
Message Re: Problème de gestion de l'album
Vérifie la taille des images en question : chez moi, elles font toutes 50 pixels de côté, ce qui n'est pas compatible avec leur utilisation dans un document ; elles ne sont là que pour permettre un aperçu dans l'album.
Je persiste donc à dire que les images elles-mêmes ne sont pas sauvegardées dans les albums.
Si tu veux pouvoir les réutiliser d'un numéro à l'autre de ta "feuille de chou" (aux mêmes emplacements, je suppose ?) il vaut mieux les mettre dans des gabarits de pages.

_________________
Photographe en Cévennes
Mes livres-photos réalisés avec Scribus


12 Nov 2017, 22:12
Profil Site Internet
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Les photos sont très légères (6 Ko : 100 x 100).
J'ai testé avec l'album "Principal" qui est dans C:\users\mon nom\AppData\Roaming\Scribus\Scrapbook\main\ et lorsque je mets un objet dedans j'obtiens dans ce dossier :
un dossier au nom de l'objet qui est vide (... et qui devrait contenir les images)
un fichier .Png au nom de l'objet contenant une miniature de l'objet
un fichier .Sce au nom de l'objet

Lorsque je colle les images de l'objet dans le dossier vide tout fonctionne. Les images devraient à priori suivre l'objet mais !!!
Ça confirme le constat fait dans le dossier Amap_Album dont les objets anciennement mis dans l'album avait le même contenu :
un dossier des images
un fichier Png
un fichier Sce
le tout au nom de l'objet.
Merci de ton aide
Alain


13 Nov 2017, 00:12
Profil
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Bonjour,
Dernier test qui semble donner raison à Tosca sur le fait que les images ne suivent pas l'objet dans l'album (... ne suivent plus.) car en allant dans gestion des images / rechercher et en spécifiant le chemin du dossier "Images" contenant toutes les photos de l'Amap, ça fonctionne. Le problème c'est que Scribus ne met pas les images dans l'album MAIS lors de la récupération de l'objet dans l'album pour le glisser dans le document c'est la qu'il va les chercher. De fait il ne risque pas de les trouver.

Ne pensez-vous pas qu'il faudrait que je réinstalle Scribus car il y a une "bizarrerie", une incohérence que je ne vois pas comment sortir.
A réinstaller Scribus, y-a-t-il un risque de perdre des données, paramétrage, préférences ou autres ? Dois-je faire des sauvegardes avant ? Dois-je désinstaller Scribus avant de le réinstaller ?

Merci de votre aide
Alain


13 Nov 2017, 10:24
Profil
P'tit timide
P'tit timide

Inscription: 30 Mai 2011, 22:48
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Bonjour,
Comme indiqué par Tosca, par défaut, seul le chemin du dossier des images est enregistré par Scribus, pas les images elles-mêmes.
Mais il y a une astuce (qui sera intégrée dans la future version de Scribus) qui permet d'incorporer les images.
Il faut charger les images dans un logiciel ad-hoc comme Gimp, et les copier (Edition-Copier).
Puis, dans Scribus, faire un clic-droit dans le cadre image et choisir "Coller l'image à partir du presse-papier".
L'image est ainsi incorporée. Pratique pour les images permanentes comme les logos ou autres.
Bien sûr, la taille du fichier sla est augmentée d'autant.


13 Nov 2017, 11:02
Profil
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Bonjour,
"seul le chemin du dossier des images est enregistré par Scribus, pas les images elles-mêmes"

A priori pas chez moi. OK pour "pas les images elles-mêmes" MAIS pas "seul le chemin du dossier des images est enregistré par Scribus" car chez moi Scribus stocke le chemin de l'album et pas celui des images. Et c'est la le problème.
En allant dans le gestionnaire des images j'obtiens le chemin des images qu'il ne trouve pas, et ce chemin c'est celui de l'album.

Je dois avoir un problème de paramétrage ou de gestion de l'album que je ne fais pas correctement.
Dans une version précédente Scribus devait stocker l'image dans le dossier de l'album, non ? C'est ce que je vois en regardant les anciens objets dans le dossier "Album" ? Et c'est pour ça que les "vieux" objets de l'album fonctionnent.

Je n'y comprends rien.
Merci !
Alain

PS. J'ai regardé la date de mise dans l'album des objets qui fonctionnent (le dernier est du 09/09/2016). J'ai du installé la 1.4.6 après car la date du "uninst" est du 27/12/2016. Peut-on connaître la version de Scribus avec laquelle a été créé un document ?


13 Nov 2017, 11:54
Profil
Moulin à paroles
Moulin à paroles

Inscription: 12 Fév 2009, 17:54
Messages: 335
Répondre en citant le message
Message Re: Problème de gestion de l'album
Personnellement, je n'ai pas vu de différence de fonctionnement depuis plusieurs années. Il est possible qu'il y a 6 ou 7 ans (lorsque j'ai fait mes tout premiers bouquins), les images aient été sauvegardées dans les albums, mais ça n'est pas (plus ?) le cas depuis très longtemps.
Remarque : peut-être y a-t-il une différence entre l'album principal (celui créé d'office) et ceux créés par l'utilisateur, puisqu'ils ne semblent pas être enregistrés au même endroit et/ou exactement de la même manière.

_________________
Photographe en Cévennes
Mes livres-photos réalisés avec Scribus


13 Nov 2017, 15:17
Profil Site Internet
Moulin à paroles
Moulin à paroles

Inscription: 31 Mar 2012, 17:26
Messages: 191
Répondre en citant le message
Message Re: Problème de gestion de l'album
le bug a été corrigé en avril...

https://bugs.scribus.net/view.php?id=12831

ça va être dans 1.4.7...


13 Nov 2017, 16:14
Profil
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Ce bug doit dépendre du système d'exploitation car voici la chronologie de mes installations :
PC portable Toshiba sous Windows Vista 32 bits
12/10/2009 : Installation de Scribus 1.3.3.13 (album OK)
28/09/2015 : Installation de Scribus 1.4.5 (album OK)
13/11/2017 : Installation de Scribus 1.4.6 (album OK)
PC fixe sous Windows 7 64 bits
26/12/2016 : Installation de Scribus 1.4.6 (problème album)
13/11/2017 : Installation de Scribus 1.4.6 64 bits (toujours problème album)

Ce qui veut dire que Scribus 1.4.6 fonctionne sur mon ancien PC sous Vista ... en transférant les images dans l'album.
Par contre sur mon nouveau PC, même en réinstallant Scribus Windows 7 64 bits, c'est toujours pareil : pas de transfert des images dans l'album mais utilisation comme chemin d'accès de ces images, le chemin de l'album.
Ça ne fonctionne que si je transfert les images de l'objet dans le dossier créé par Scribus dans l'album.

Mais comme à priori ce problème sera réglé dans la version 1.4.7 je vais attendre patiemment. Je n'ai pas non plus une utilisation impérative de l'album. Par rapport à ce que m'apporte Scribus ce n'est rien.
Merci à tous.
Alain


13 Nov 2017, 17:34
Profil
Moulin à paroles
Moulin à paroles

Inscription: 31 Mar 2012, 17:26
Messages: 191
Répondre en citant le message
Message Re: Problème de gestion de l'album
si c'est urgent, ici il y a un snapshot de 1.4.7svn pour windows, daté la fin de juillet:

https://sourceforge.net/projects/scribu ... 1.4.7.svn/

ciao
a.l.e

p.s.: la version du 13.11.2017 ne pouvait pas être ok... je ne crois pas vraiment...


14 Nov 2017, 10:04
Profil
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
Bonjour,
... " la version du 13.11.2017 ne pouvait pas être ok "

Je viens de rebrancher mon portable pour de nouveau tester la 1.4.6 télécharger hier. Et l'album fonctionne nickel. Les images sont dans l'album.
Le fichier Scribus.exe occupe 8875 Ko sur le disque. Je ne crois pas m'être trompé. En regardant le "à propos de Scribus" j'obtiens :
Scribus 1.4.6 03/01/2016

Je m'absente, mais dès que possible je reviens vers vous
Alain


14 Nov 2017, 10:37
Profil
Moulin à paroles
Moulin à paroles

Inscription: 31 Mar 2012, 17:26
Messages: 191
Répondre en citant le message
Message Re: Problème de gestion de l'album
je ne crois pas que les différentes downloads de la même version de scribus puissent produire cette différence.

à ce point ce n'est pas très important de savoir où se trouve la cause du problème (du moment où ça a été reconnu et corrigé dans scribus même), mais uniquement une différence entre vista et windows 7 pourrait l'expliquer...

ou bien de la magie : - )

si tu peux attendre ou installer le snapshot, je crois que nous pouvons considérer ce problème résolu...


14 Nov 2017, 11:15
Profil
P'tit timide
P'tit timide

Inscription: 11 Nov 2017, 13:39
Messages: 9
Répondre en citant le message
Message Re: Problème de gestion de l'album
... Serais-je ensorcelé ?
La notion de 32 / 64 bits est-elle importante pour Scribus et y-a-t-il une version spécifique pour chacune de ces versions de système Windows ?
Tosca : tu es sous quel système d'exploitation ?
Pour le reste c'est OK pour attendre la 1.4.7 et fermer ce post (après les réponses d'Ale et Tosca si possible).
Merci !
Alain


14 Nov 2017, 12:01
Profil
Afficher les messages postés depuis:  Trier par  
Répondre au sujet   [ 18 messages ]  Aller à la page 1, 2  Suivante

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 6 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Forum style by ST Software for PTF.
Traduction par: phpBB-fr.com