1.3.4, 1.3.3.12, 1.3.5: quelle version utiliser?

Un espace d'aide et de dialogue dédié à  Scribus, logiciel Libre de PAO
Le_Tigre
Messages : 935
Inscription : 07 nov. 2005, 18:25
Contact :

1.3.4, 1.3.3.12, 1.3.5: quelle version utiliser?

Message par Le_Tigre »

Bonjour

un petit point concernant les différentes versions de Scribus à utiliser, maintenant et dans l'avenir.

Avant tout, et suite à pas mal de mauvais choix: n'utilisez PAS la version 1.3.4 sauf si vous savez vraiment pourquoi. Si vous découvrez ou débutez avec Scribus, choisissez la version 1.3.3.13 (edit de mai 2009)

La 1.3.4 vient de sortir. Avec beaucoup de nouveautés, parmi lesquelles:
- gestion des bords perdus
- nouveau moteur de texte, avec style de caractères
- nouvelles icônes
- etc. (Release note en anglais et en pdf ici)

Mais mais mais il ne faut pas utiliser cette version pour débuter sur Scribus. (edit d'août 2008).

Pour télécharger, c'est ici: http://sourceforge.net/project/showfile ... _id=125235 (et choisir scribus-devel)

Mais attention: la nouvelle gestion des caractères implique des modifications sur des documents créés par les versions 1.3.3.x

Donc ne changez pas de version si vous ne voulez pas perdre des calages précis (on parle ici de textes longs) de documents non terminés. De même, parce qu'elle est plus fraîche, la 1.3.4 intègrera sans doute plus de petits bugs que la 1.3.3.x.

Sauf à compiler vous-même, vous ne pouvez pas avoir deux versions 1.3.3.x et 1.3.4 en parallèle sur Linux (sauf peut-être Debian/Ubuntu? Je n'ai plus suivi). Sur Windows, je ne sais pas (mais il me semble que oui).

La version 1.3.3.10 viendra corriger des choses à partir de la 1.3.3.9.

La version 1.3.5 devrait sortir d'ici un mois ou deux: il s'agit d'une version purement technique (passage de Qt3 à Qt4), donc il n'y aura aucun changement par rapport à 1.3.4

Ensuite, une version 1.3.6 sera développée, intégrant les correctifs et ajouts à partir de la 1.3.5 (donc de la 1.3.4 mais portée sur Qt4).

Voilà les infos que je pouvais vous donner.

EDIT: je change le titre pour être à jour. Et je rappelle que depuis le 12 juin 2008, c'est la 1.3.3.12 la version stable et officielle. Tout ce qui est dit sur la 1.3.4 et la 1.3.5 reste valable.

Nouvel EDIT: pour être totalement clair, voici en mai 2009, un rappel des différentes versions:
- 1.3.3.13 est la version stable à utiliser pour un débutant
- 1.3.4 est une version (officiellement stable) à déconseiller sauf pour usage précis
- 1.3.5 est relativement instable mais riche de nombreuses nouvelles fonctions (attention, pas de compatibilité descendante, donc on ne peut pas ouvrir avec la 1.3.3.13 un fichier fait avec la 1.3.5). Elle existe en deux branches, comme expliqué sur ce fil
Dernière modification par Le_Tigre le 20 mai 2009, 10:02, modifié 5 fois.
[url=http://www.le-tigre.net/]Le Tigre, curieux journal curieux[/url]
rore
Administrateur
Administrateur
Messages : 755
Inscription : 05 août 2005, 15:24
Localisation : Bretagne
Contact :

Message par rore »

Je pense que ce message pourra intéresser tous ceux qui sont peut-être un peu perdu dans les versions donc je le passe en post-it.

(déjà à l'époque de scribus 1.2.x et 1.3.x - si je me souvient bien - il y avait pas mal d'embrouilles :) )
Obruni
Messages : 4
Inscription : 17 mai 2007, 13:43
Localisation : 93
Contact :

Merci le Tigre

Message par Obruni »

Bonsoir,
Merci de ces éclaircissements.
Faire est facile, agir est risqué.
Le_Tigre
Messages : 935
Inscription : 07 nov. 2005, 18:25
Contact :

Précisions pour Debian/Ubuntu

Message par Le_Tigre »

Tant qu'on y est, voici des infos (en anglais, depuis la ML de Scribus) pour Debian et Ubuntu, d'Alex:

Hello Debian and Ubuntu users of Scribus. Since Debian Etch and Ubuntu Feisty
were recently released I rearranged our Debian/Ubuntu package archives.

If you are using Ubuntu Feisty then use the following line in your
/etc/apt/sources.list:

deb http://debian.scribus.net/debian/ feisty main restricted
or
deb http://debian.tagancha.org/debian/ feisty main restricted

Scribus 1.2.x branch is officially deprecated. All my "scribus" packages
(debian: etch/lenny/sid and ubuntu: dapper/edgy/feisty) are at version 1.3.3.x
now.

scribus-ng is starting to track cutting edge code - 1.3.4cvs right now.
If you try scribus-ng and it crashes or does something weird you should file a
bug at http://bugs.scribus.net and switch back to the stable "scribus". If
there is something in the 1.3.4cvs that you _really_ need then by all means
try running scribus-ng. At the moment the only branch to have this new
scribus-ng package is Debian/unstable in our repositories.

Regards,

Alex.
[url=http://www.le-tigre.net/]Le Tigre, curieux journal curieux[/url]
Papageno3
Messages : 76
Inscription : 05 nov. 2005, 00:52
Localisation : Genève
Contact :

Re: 1.3.4, 1.3.3.10, 1.3.5: quelle version utiliser

Message par Papageno3 »

Bonsoir Le Tigre :D
Merci pour toutes ces bonnes infos.
Par contre,
Le_Tigre a écrit :la nouvelle gestion des caractères implique des modifications sur des documents créés par les versions 1.3.3.x
Donc ne changez pas de version si vous ne voulez pas perdre des calages précis (on parle ici de textes longs) de documents non terminés. De même, parce qu'elle est plus fraîche, la 1.3.4 intègrera sans doute plus de petits bugs que la 1.3.3.x.

ça c'est pas une bonne nouvelle, je m'apprêtais à travailler mes fichiers fais avec la V 1.3.3.8 dans la V 1.3.4 ...
Bref on va pas se plaindre, j'adore scribus. Mon imprimeur beaucoup moins par contre.

Il me dit que mes PDF sont mauvais, que tous les caractères de texte sont reconnus comme des images, au lieu d'être du simple texte, et j'ai des soucis aussi avec les couleurs. J'ai des images en niveau de gris qui apparaissent chez lui avec de la couleur, alors que scribus m'assure que la séparation des couleurs est bien effectuée, et que j'ai que du noir...

Faut que j'éclaircisse ça je crois que je vais aller demain avec mon programme pour lui montrer comment j'exporte mes PDF. Peut-être il verra ce que je fais faux.
Le fichier est là, mais apparemment pour l'instant ma ligne semble down : http://imsp.homelinux.net/public/mas_sp/

Cordialement,
Papageno3 8)
http://www.dominique-bedier.com
FeIZocE
Admin de .:Calcyum.org:.
Messages : 321
Inscription : 20 août 2007, 17:53

Message par FeIZocE »

tous les caractères de texte sont reconnus comme des images, au lieu d'être du simple texte

Salut. Tu vectorises tes polices? Ca vient peut-être de ça qu'elles soient reconnues comme des images.
Sinon, pour créer tes pdf, tu fais un .ps pour ensuite utiliser ghostscript? Si ce n'est pas le cas, tu devrais... Par défaut, les logiciels de mise en page n'exportent pas en PDF avec une efficacité à toute épreuve, et les imprimeurs ont tendande à râler quand ça multiplie les BAT et les manips :D
.: [url=http://www.calcyum.org]Calcyum.org[/url] :.
[i]Fortifiez votre créativité open source![/i]
Papageno3
Messages : 76
Inscription : 05 nov. 2005, 00:52
Localisation : Genève
Contact :

Message par Papageno3 »

FeIZocE a écrit :Tu vectorises tes polices? Ca vient peut-être de ça qu'elles soient reconnues comme des images.

Bonsoir FeIZocE et merci pour ton message :D

Oui, c'est ce que j'ai aussi pensé, les polices sont sûrement vectorisées. Sauf que je n'arrive pas à voir où je fais la fausse manip, car au moment de l'exportation en PDF, je clique seulement sur "incorporer les polices", et pas sur "tout vectoriser"...

Sinon, pour l'exportation en PDF, non je ne fais pas de .ps j'exporte directement en PDF et jusque là je n'avais aucun souci...

Bon, je vais essayer ça. Mais je tiens vraiment à faire le point là-dessus avec mon imprimeur, car je n'ai bien entendu pas l'intention de suivre son conseil (passer à Indesign...), et j'ai beaucoup de maquettes à lui donner dans un avenir proche. En plus, je ne peux pas changer d'imprimeur, c'est l'Université...

Papageno3 8)
PS: je suis sous Debian etch, avec scribus 1.3.3.8
http://www.dominique-bedier.com
Papageno3
Messages : 76
Inscription : 05 nov. 2005, 00:52
Localisation : Genève
Contact :

Message par Papageno3 »

FeIZocE a écrit :Tu vectorises tes polices?

Bonjour :D

Je viens de regarder, et sur la version 1.3.3.8 de scribus il n'offre pas la possibilité au moment de l'exportation en PDF de vectoriser les polices. D'après ce que j'ai vu ce n'est possible qu'à partir de la version 1.3.4

Alors où est ma fausse manip?

Bonne journée,
Papageno3 8)
http://www.dominique-bedier.com
FeIZocE
Admin de .:Calcyum.org:.
Messages : 321
Inscription : 20 août 2007, 17:53

Message par FeIZocE »

Bah ça vient peut-être pas de là :?
Les imprimeurs conseillent TOUJOURS un soft avec lequel ils ont leurs affinités, normal c'est des prescripteurs. Moi quand je suis passé à InDesign mon imprimeur s'est foutu de ma gueule, et aujourd'hui il tourne plus qu'à ça ou presque... avec Publisher :lol:
Mais quel que soit le soft, pour un boulot impeccable, c'est PostScript > PDF.
.: [url=http://www.calcyum.org]Calcyum.org[/url] :.
[i]Fortifiez votre créativité open source![/i]
Papageno3
Messages : 76
Inscription : 05 nov. 2005, 00:52
Localisation : Genève
Contact :

Message par Papageno3 »

Salut FeIZocE :D

Merci de me soutenir dans mes misères :?

Je viens de faire l'essai de d'abord imprimer mon fichier en .ps , puis le convertir en pdf.
J'ai exécuté pour ça avec la commande (du man) ps2pdf13 /nom_du_fichier.ps /nom_du_fichier_final.pdf et le résultat est plutôt fantaisiste. Les images ont toutes disparu, et les couleurs sont curieuses :shock:

Je vais aller maintenant chez l'imprimeur avec mon portable, lui montrer comment j'exporte mes pdf avec scribus. On va voir s'il voit des choses pas correctes dans mes manips.

A+, Papageno3 8)
http://www.dominique-bedier.com
Le_Tigre
Messages : 935
Inscription : 07 nov. 2005, 18:25
Contact :

Message par Le_Tigre »

Oups les amis! Les pdf exportés par Scribus sont parfaits pour les imprimeurs (les développeurs de Scribus sont même obsédés par ça). Tout est prévu pour que ça se passe bien.

Pas besoin du tout de passer par du ps.

Je te conseille de lire (sur ce forum et ailleurs, notamment sur wiki.scribus.net) de la doc sur l'export pdf de Scribus.

Tes polices sont vectorisées? C'est (sans doute) parce que c'est des .ttf et que Scribus, par précaution, préfère les vectoriser que les incorporer (les ttf ne sont pas hyper fiables dans un pdf). Je ne vois pas en quoi ça pose un problème à ton imprimeur (à moins qu'il ne veuille retoucher ton texte...)

P.S. Papageno, tu devrais peut-être créer un autre fil que celui-ci (consacré aux différences de version) et lister tes problèmes point par point.
[url=http://www.le-tigre.net/]Le Tigre, curieux journal curieux[/url]
Papageno3
Messages : 76
Inscription : 05 nov. 2005, 00:52
Localisation : Genève
Contact :

Message par Papageno3 »

Le_Tigre a écrit :tu devrais peut-être créer un autre fil que celui-ci (consacré aux différences de version) et lister tes problèmes point par point.


Bonjour Le_Tigre :D

Oui oui tu as raison, je vais ouvrir un autre fil. Surtout que tout ça est loin d'être fini...mais j'attends les premiers résultats de l'imprimerie que je devrais avoir lundi (je suis très sceptique quant à ces résultats).

Cordialement, Papageno3 8)
http://www.dominique-bedier.com
Aggie
Messages : 349
Inscription : 18 sept. 2005, 09:25
Localisation : Groland (partie Gascogne)
Contact :

Message par Aggie »

Là, toujours aussi paumée par les versions.
je scotche sur la 1.3.4, mais étant sous Ubuntu Gutsy, je ne sais plus à quel dépots je dois me connecter en cas de mise à jour...
Ubuntu 14.04 LTS (64) | Scribus 1.4.2 en prod. | Pentax K10D & Sony RX100 | Photos | Graphiste 100% libre
eclipse
Messages : 864
Inscription : 05 sept. 2007, 18:16
Contact :

Message par eclipse »

La version 1.3.4 existe et restera en l'état. Plus de mise à jour, ou de correctifs divers sur celle-ci. Si un bogue est trouvé, il sera corrigé pour une autre version (voir plus bas)

Les développeurs préfèrent se concentrer sur la version très stable 1.3.3.11, ainsi que la version de développement 1.3.5.

Donc, comme dirait le Tigre, si vous devez utiliser Scribus en production, utilisez alors la version 1.3.3.11.
Aggie
Messages : 349
Inscription : 18 sept. 2005, 09:25
Localisation : Groland (partie Gascogne)
Contact :

Message par Aggie »

Et quels sont les dépôts pour ce faire?
Ubuntu 14.04 LTS (64) | Scribus 1.4.2 en prod. | Pentax K10D & Sony RX100 | Photos | Graphiste 100% libre
Répondre