Voir les messages sans réponses | Voir les sujets actifs Nous sommes le 20 Oct 2018, 18:06



Répondre au sujet  [ 4 messages ] 
Tablette Wacom en twinview + Gimp, c'est possible ? 
Auteur Message
Nouveau venu
Nouveau venu

Inscription: 31 Déc 2007, 11:21
Messages: 1
Répondre en citant le message
Message Tablette Wacom en twinview + Gimp, c'est possible ?
Bonjour,

Je viens d'acheter une tablette Bamboo fun A5.

J'ai bien reussi a installer la tablette avec les derniers pilotes de chez linuxwacom (7.9)

La tablette fonctionne correctement en mode desktop (la tablette couvre donc les 2 écrans), mais du coup l'apsect ratio est faussé (logique...)

J'ai donc configurer mon Xorg de façon a ce que la tablette ne soit active que sur l'écran principal.

Mais voila, dans ce mode gimp bug, la brosse n'est plus du tout aligner sur le curseur (lorque la tablette est activée dans gimp, en mode souris ca fonctionne, mais du coup pas de pression...).

En gros si je veux pointer
ici : X
je doit mettre mon curseur
ici : X

Sachant qu'il y'a bien 1000px de décalage, plutôt génant voir inutilisable.

J'ai eu beau chercher je n'ai pas encore trouver de solution. Quelqu'un a rencontrer le même problème que moi mais la solution ne m'a pas franchement paru évidente a mettre en place.

Peux-être que ca parlera plus à l'un d'entre vous !

http://sourceforge.net/mailarchive/foru ... om-discuss

Je vous joint la partie de mon xorg.conf concernant la Wacom

Code:
##tablette graphique wacom bamboo fun
#
Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "stylus"
        Option "Twinview" "horizontal"
        Option "TVResolution" "1152x864,1680x1050"
        Option "ScreenNo" "1"
        Option "USB" "on"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "eraser"
        Option "Twinview" "horizontal"
        Option "TVResolution" "1152x864,1680x1050"
        Option "ScreenNo" "1"
        Option "USB" "on"
EndSection

##cette section est elle utile sachant que je n'ai pas de souris wacom ??

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "cursor"
        #Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
        Option "Twinview" "horizontal"
        Option "TVResolution" "1152x864,1680x1050"
        Option "ScreenNo" "1"
        Option "USB" "on"
EndSection




Suis je le seul a vouloir utiliser Gimp avec une tablette en dual screen ? :o

A j'oubliais, je sous Debian Lenny et KDE.

Merci de votre aide


LeXa.

PS : a noter que le décalage change en déplacant la curseur, et le phénomème se produit aussi sur d'autre applications, comme "krita" par exemple...


31 Déc 2007, 16:32
Profil Site Internet
P'tit timide
P'tit timide

Inscription: 08 Avr 2006, 09:26
Messages: 12
Répondre en citant le message
Message 
Salut, j'ai chez moi le même problème que toi et je suis bien décidé à en découdre.

J'ai une wacom graphire 4 avec une gentoo et les derniers linuxwacom.
Les options TwinView sont les mêmes à l'exception de l'option ScreenN°1
dont je ne connais pas l'utilité.

Bref je vais continuer à plancher dessus.


04 Mar 2008, 00:54
Profil
P'tit timide
P'tit timide

Inscription: 15 Jan 2008, 14:38
Messages: 4
Répondre en citant le message
Message 
Salut
Je relance ce billet...
J'ai le même pb et j'ai trifouillé pendant tout le week end en vain !
- Soit j'ai pas de décalage mais bizarrement le curseur ne couvre pas tout l'écran... j'ai joué avec TVResolution puisqu'il semble ne pas tenir compte de mes entrées de résolution, j'ai des résultats assez différents, mais il me manquait toujours une partie d'écran non couvert par le curseur..
- Soit j'ai le décalage sous Gimp, inkscape, mypaint, krita etc. (l'horreur !)

J'ai parcouru pas mal de forums mais je n'ai pas trouvé de solutions, apparement ce serait un bug (j'ai lu qq bug reports à ce propos) dû au twinview avec des écrans de résolutions différentes. ? à confirmer ?

Finalement j'ai opté pour désactiver le twinview pour la wacom, et de rajouter l'option KeepShape... Ma tablette couvre les 2 écrans, mais le ratio est respecté, le gros inconvenient, c'est que la partie active de ma tablette que j'utilise pour mon écran principale fait à peine plus d'un 1/4 de la surface totale de la tablette (A5) donc c'est tout petit... C'est en attendant... au moins quand je dessine un carré, j'ai un carré sur l'écran et non pas un rectangle!

Je suis sur Kubuntu 7.10 amd64 nvidia 7900GS avec une Wacom Intuos2 A5....

Voici la partie de mon xorg.conf qui concerne le stylus :

Code:
Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "ScreenNo" "1"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "PressCurve" "0,15,85,100"
    Option         "KeepShape" "on"
#Option "TVResolution" "1280x1024,1024x768"
#Option "Twinview" "horizontal"
#   Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection


En espérant que qqu'un a trouvé la solution...


21 Avr 2008, 11:12
Profil
P'tit timide
P'tit timide

Inscription: 15 Jan 2008, 14:38
Messages: 4
Répondre en citant le message
Message 
Youhou !!!
J'ai enfin ce que je voulais :
- La tablette restreinte sur un écran (mon écran plat 1280x1024)
- Toute la surface de la tablette utile (ce n'était pas le cas en twinview sur 2 écrans)
- Le ratio respecté (un carré dessiné sur la tablette me donne un carré sur l'écran)
- Pas de décalage entre le curseur et le tracé (sous gimp inkscape mypaint etc.)

Ce qui a changé :
- Une upgrade de ma kubuntu de 7.10 -> 8.04 (surement le plus probable dans l'amélioration de la situation)
- Encore du trifouillage de xorg.conf dont je laisse la partie "stylus" le seul changement susceptible d'avoir joué c'est TVResolution --> TVResolution1 (à tester, mais là ça fait tellement de temps que je trifouille, je ne touche plus à rien !) :
Code:
Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "TVResolution1" "1280x1024"
#    Option         "ScreenNo" "1"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "PressCurve" "0,15,85,100"
    Option         "KeepShape" "on"
    Option         "Twinview" "horizontal"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection


Ah précision, le reste du xorg.conf a été généré par nvidia-settings (j'utilise les drivers proprios, oui je sais....) et je suis en mode twinview

j'espère que ça aidera d'autres cas !


29 Avr 2008, 11:52
Profil
Afficher les messages postés depuis:  Trier par  
Répondre au sujet   [ 4 messages ] 

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages

Rechercher:
Aller à:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Forum style by ST Software for PTF.
Traduction par: phpBB-fr.com